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Introduction

* These slides will show you how to build a

simple Stateflow model using Matlab release
2018a.

 This is the version of Matlab we use in the lab.



Power Switch Simulink Model

* Simulink model of a power switch that toggles
on and off at the zero crossings of a sine wave
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Inside the State Chart

* Two states of the power
switch: on and off

Power_on
* Transitions between the [ } -
states happen |
whenever the event S [’W‘“” }

“Switch” occurs

* By default, the initial
state is “off”



Running the Simulation

®e  PowerSw itch
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e Edit View Display Diagram Simulation Analysis Code Tools Help

* Open the scope by
clicking on it
* Run the simulation

selecting “run” &
simulation menu, or by
clicking the green arrow ., s0s
ile Tools View Simulation Help
* There are many scope e T

options available from
the pull-down menus
that allow you to zoo
in or out, log data,
change the color and
line width, etc.




Create Slmulmk I\/Iodel

Launch Simulink
Create a Blank Model

from the Simulink Start Page

Open the Library Browser

from the View menu

Save the model with a name
like “my_switch”

Near the bottom of the
Library Browser you will find
Stateflow.~Select it and the
Stateflow blo
appear on the rig
the browser
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Add Statechart to Simulink Model

=] Enter search term |v | Ay «
Stateflow
v Simulink
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Drag and drop statechart from the
browser into the Simulink model. The
default name is “Chart,” so you’ll
want to change it to something like
“on_off”
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Adding States to a Statechart

Open statechart “on_off” by
double clicking

Drag two states from the wE——

menu on the left side of the © [Falmy_switch » Fon_off
chart into the model

The first will have an arrow /7
entering it. Place it on the '
lower right.

Name the states “Power_on”
and “Power_off” by editing
‘ <)
Ready 100% VariableStepAuto
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the “?” in the upper left
corner

To delete a state, just select it
and hit “delete”

\.H n‘
@



Creating Transitions between States

To create a transition between
states, hold the cursor over
the border of the starting state

— it will turn into crosshairs | on_off |

© [*a|my_switch » [Jon_off bd
Hold down the mouse button i

and drag the mouse to the

terminal state — this will create — [~ |

a transition (denoted by an f N

arrow) connecting the states . AN T.

Click on the transition and 0 \ Swich e PO

replace the resulting “?” with ~ © e

the name of the event that

causes the transition. In this Re'ady — —

example, we’ll call our event
“Switch”*

* Lower case “switch” is a reserved word in Stateflow and will cause an
error. Be sure to call it upper case “Switch” or a different name!



The Default Transition

 The arrow entering the first
state added to the chart

indicates the initial i

transition, or initial state. © [Lalmy_switch » Qon.off ”
* Theinitial state may be o

changed by clicking on the = { }

arrow and hitting delete. : = )]
* A new default transition = \_Swich S oweror

may be added by dragging @ *f [ }

the arrow icon from the

Ready 126% VariableStepAuto

menu to the border of the
desired initial state



Adding an Event

From the “Chart” pull-down
menu, select “Add Inputs and
Outputs” and then “Event
Input from Simulink”

A window will open allowing
you to name the event
(“Switch”), and to specify that
the event triggers on the rising
edge of the sine wave

You may get an error message
warning you to fix an

initialization problem. Be sure
to do so!

Stateflow (chart) my_switch/on_off
File Edit View Dlsplay-S|muIat|on Analysis Code Tools Help
Parse Chart
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CROLVEL RS Add Inputs & Outputs L@l Data Input From Simulink
& Add Other Elements > Data Output To Simulink ‘
Add Pattern In Chart > Event Input From Simulink
E3 Power_on Insert Pattern On Selection | 2 Event Output To Simulink
Save Pattern
() 5 Message Input From Simulink
o Create Container > Message Output To Simulink
T Format >
“a ( Arrange >
u N Library Link
® Decomposition >
e Execution Order
Subchart Mappings...
Properties...
Ready 125% VariableStepAuto
File Edit View Display Chart Simulation Analysis Code Tools Help
[ on_off I

© [*amy_switch » [FJon_off

(i) Chartol input event Switch. It is strongly advised to turn on its 'Execute Chart At
O} Initialization' property. Click here to automatically fix it. Otherwise the chart may be uninitialized when the
% execution starts, and this may cause unintended behaviors.
"\ 8witch
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Open the Model Explorer

¢ N a V i g a te to t h e IVI O d e | XK ) Stateflow (chart) my_switch/on_off

File Edit-DispIay Chart Simulation Analysis Code Tools Help

Explorer by selecting o I ——
from the “View” menu

. [*] Simulink Project
on_off E Model Dependency Viewer > t1] Base Workspace ;

© |Pajmy_ Diagnostic Viewer Data Dictionary v
Q ] Requirements at This Level aliMecciworkapsce yF
The Model Explorer lets { Py spctr 1
ymbols
e = Viewmar ks >
you ed It the event you 9 Configure Toolbars
. - Y V Toolbars
have just defined and = ‘&
& 3
add new events SR :
v/ Smart Guides
A MATLAB Desktop
Ready 125% VariableStepAuto

The Model Explorer is

shown on the next page



The Model Explorer

File Edit View Tools Add Help

Pl 3 B ) & B M4 88 & G &
Search: by Name v Name: @4 Search
Model Hierarchy =2 Contents of: my_switch/on_off (only)

v ¥ Simulink Root
1 Base Workspace
> [%al my_switch_2018a*
v [%a] my_switch*
5] Model Workspace
& Configuration (Active)
[ Embedded Coder Dictionary
|=% Simulink Design Verifier results
» 3 on_off

A

Column View:  Stateflow T Show Details

Name Scope Port Resolve Signal DataType Size InitialvValue CompiledType
& switch Input 1

Contents Search Results

- = = —r

Filter Contents

1 of 6 object(s)

CompiledSize

Trigger
Rising

=<

Chart: on_off

General Fixed-point properties

Name: on_off

Machine: (machine) my_switch
Action Language: MATLAB <
State Machine Type: Classic <
Update method: Inherited C  Sample Tir

User specified state/transition execution order
Export Chart Level Functions

v Execute (enter) Chart At Initialization
Initialize Outputs Every Time Chart Wakes Up

Cnahla Qiinar Ctan Camantine

Revert Help Apply

* Note the event is named Switch, it is triggered on Rising edges,
and the Execute Chart at Initialization box is checked.
* |f there were multiple events, they would each have a different Port

number



Adding the Sine Input

Return to the top-level Simulink
Diagram

The statechart “on_off” now has _muwe
an input port. If you examine it
closely, you will see that the port
represents the rising edge of a
signal (because we specified our R
trigger to be “rising edge”) L
Add a sine wave input and a

scope from the “sources” and J S
“sinks” blocks in the Library _
Browser

Connect them as shown. You may

use the default sine wave
parameters
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Ready 240% VariableStepAuto



Configuration Parameters

From the “Simulation” menu select “Model Configuration Parameters”

Expand the window by clicking “Solver Details”

Specify Stop Time = 100 and choose “Fixed Step” solver “discrete (no continuous
states). Specify a sample time of 0.001

Be sure to hit “Apply” before closing the window

Q

Solver Simulation time
Data Import/Export . )
» Optimization Start time: 0.0 top time: |100.0

» Diagnostics
Hardware Implementation Stcicrions
Model Referencing Type: |Fixed-step -
Simulation Target
» Code Generation v Additional parameters
Fixed-step size (fundamental sam

Tasking and sample time options
Periodic sample time constraint: |Unconstrained v
Treat each discrete rate as a separate task
Allow tasks to execute concurrently on target
Automatically handle rate transition for data transfer

Higher priority value indicates higher task priority

OK Cancel Help Apply



Running the Simulation

* When you run the simulation, you should see the
Power_on and Power_off states change color at each
rising zero crossing of the sine wave.



Add Data to Count Transitions

If we want to count the number of transitions from Power_on to
Power_off, we need to add an output and an action to our statechart

Go back to the “Add Inputs and Outputs” menu, but this time select “Data
Output to Simulink” to add data “counter’ with Sqope “Output”.

Specify counter as type double, and with initial vajue zero

—8 O O  Stateflow (chart) my_switch /on_off *
File Edit View Display - Simulation Analysis Code Tools Help
Parse Chart .
B @ < 1 P > @ E
Refresh Blocks 2K :
on_off Group & Subchart >

v

© [Pajmy_switch » FJon_ggrT] Inputs & Outputs Data Input From Simulink

I ¢ B O 00 B ®

Add Other Elements Data Output To Simulink

power.on Add Pattern In Chart Event Input From Simulink
Insert Pattern On Selection Event Output To Simulink
Save Pattern
Message Input From Simulinl
Format > Message Output To Simulink

Arrange >
Library Link

Decomposition >
Execution Order

Subchart mappings...
Properties...

vy v

100% FixedStepDiscrete

Output
ast resolve to signal object

Size: -1

gmplexity: nherited
Type: double

neral Logging Description

Lock data type against Fixed-Point tools

Unit (e.g., m, m/s*2, N*m):

inherit

Initial value: = Expression

Limit range

Minimum:

Add to Watch Window

OK

C| Port: | 1 S
Variable size
A
L4
v >
Sl, English, ...

O

Maximum:

Cancel Help Apply



Increment the Counter

Increment the counter every
time the event “Switch”
occurs by placing the action
“counter = counter + 1” in
{curly braces} following each
occurrence of “Switch.”

End the action with a
semicolon inside the closing
brace to prevent the value of

the counter from being
printed to the screen each

time it is incremented

[ on_off l

B ®|e

@ D¢y o0

[*a] my_switch » [Jon_off

Power_on -
\ \\\ y
< S Power_off
Switch{counter=counter+1;}

r

. Switch{counter=counter+1;}
N °

142%

FixedStepDiscrete



Counting the Transitions

* Add a display block

on_off

my_switch [
from the Librar
orary « [P m
Browser/Sinks menu [
and connect itto the = 7
data output port . sl N
“counter” }
-F



Toggle a Bit

Genera Logging Description

Name: light

Add a new data output

Data must resolve to signal object

o I i g h t ” W i t h size: - Variable size

Complexity: Inherited

— Initial value =0 :

Lock data type against Fixed-Point tools

<>
o

N

<>

<>

Unit (e.g., m, m/s"*2, N*m): SI, English, ...

— Data Type = double

Set light =0in the  lenot]
©®  [*a/my_switch » [[Jon_off .
Power off state .
- Power_on
entry:light=1; N

Set light =1 in the N

= \\ Switch{counter=counter+1;}
Power_on state 0 2N
“u N
O A\ ~_ (Power_off
| entry:light=0;
@) Switch{counter=counter+1;} Y48

Ready 164% FixedStepDiscrete



Avoid Crossing Lines

 The output “light” is

assigned Port 2 by default, ===

and you could connect it to Y ;I_>C]
the scope as illustrated é v —
* It’s much better practiceto t -
keep your model readable - o
by not crossing lines - o

 Change ports in the Model
Explorer



File Edit View Tools Add Help
bt O3 B B
Search: by Name

Model Hierarchy

v ¥ Simulink Root
] Base Workspace
> [%a] my_switch_2018a*
v my_switch*
4 Model Workspace
& Configuration (Active)
3 Embedded Coder Dictionary
|=¥ Simulink Design Verifier results
» A on_off

v Name:

Change Port Values

o]

3 M 28 & & SE]

E
[

@6 Search

Contents of: my_switch/on_off (only)

&

Column View: = Stateflow C | Show Details

Name Scope Port Resolve Signal DataType Size InitialValue
|44 counter Out.. 2 double -1 0

light Out... 1 double -1 0

§ switch Input 1

Contents

Port selection

Filter Contents

3 of 8 object(s)

CompiledType  CompiledSize  Trigger

unknown

Rising

Search Results

Data light
General ging Description
Name: light
Scope: Output o
Data must resolve to signal object
Size: -1 Variable
Complexity: Inherited o

Type: double
Lock data type against Fixed-Point tools
Unit (e.g., m, m/s"2, N*m):

inherit

Revert Help Apply




Non-crossing Lines

e Now the model has no
crossing lines and is
easier to read.

100.0

S

counter 4> ‘
N /
on_off

my_switch ]
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Modeling Preferences

e Alternatively, you can make

your model clearer by going

NNNNNN

to the File menu on the
Simulink toolbar, select ’

counter

.
Simulink Preferences, then
select Editor Preferences IRy I SN
and choose “Line Hop”. Your T
lines will do something like { 1

that shown on the right.

* You can also use this menu
to change your font
selection and a number of
other things.

on_off

Ready 291% FixedStepAuto



my_switcl

Display a Square Wave

;. © 0 O Scope

| File Tools View Simulation Help

- 40P ® =-B-C- F&-

Data may be missin: g. Try unchecking ‘Limit data points to last’ from the Configuration Properties Logging tab.

BEdE S| e

eady

P )
light
| 16
counter——p»
4
on_off
317% auto(FixedStepDiscrete)

Ready T=100.000

Running the simulation shows a square wave that toggles between 0 and 1 at rising
zero crossings of the sine wave




Adding Data using Model Explorer

* Suppose we want to use data defined in the Matlab workspace
 We can add data to the model using Add menu in the Model Explorer

® Model Explorer
File Edit View Tools - Help
[l ;‘ £ B B “1 MATLAB Variable ~M Fﬁ = om = G,
! Simulink Parameter ~P
Search: by Name - Simulink LookupTable B @& Search
; Simulink Breakpoint ;
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T Simulink Signal NS
v ¥4 Simulink Root I .
FH Base Workspact Simulink NumericType ) .
v my_switch* Simulink AliasType nView: Stateflow H Show Details 5 of
il Model Works Simulinkc Bus ne A 'S Port Resolve Signal  DataT Size Initialvalue Compiled
53 Configuratiol Sinulink vaelant ne cope ort Resolve Signa ataType ize InitialvValue ompile
& Code for my, Configuration gter Output -2 double =10
> 55 on_off GonitiourationRe it Output 1 double 10 double
Add Custom... wer_off
wer_on
= Message litch Input 1

& Event ~E
@ Data )
Trigger
Function Call Output

BTN search Results

Add a data item




Use a Parameter Defined in Workspace

 Add data with Name “k”, Scope “parameter”, and Type “double”

File Edit View Tools Add Help

C1 0 ERP RN S @) § & M 4588 B &
Search: by Name v | Name: @4 Search
Model Hierarchy = Contents of: my_switch/on_off (only) Filter Contents Data k

v P Simulink Root

. Description
{+1 Base Workspace

' Column View: = Stateflow C  Show Details 6 of 9 object(s) v
v my_switch* v Name: k
Hal Model Workspace - - -
A :
& Configuration (Active) _INgine Scops FortjResolvel Signal Zata;’pe Size _ InitialValue Scople: Parameter s
E Code for my_switch [5s) counter Output 2 ouble -1 0 - ”
» [ on_off (i) k Parameter double -1 i -
[si¢) light Output 1 double -1 0 Cornplexity: = Inherited 2
(2 Power_off
@ Power_on Typey double
% Switch Input 1

inst Fixed-Point tools

Add to Watch Window

Revert Help Apply
Contents Search Results




Model Properties

Navigate to the Menu “File/Model Properties/Model Properties”

@00
- Edit View Display Diagram Simulation Analysis Code Tools Hel

New

3 Open...
Open Recent
Close

Save
Save As...

Simulink Project

Export Model to
Model Properties

Print

Simulink Preferences
Stateflow Preferences
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E Model Properties
‘ Link to Data Dictionary...

Chart Properties
State Machine Properties
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Ready

142%
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Model Callbacks

* Navigate to “Model Properties/Callbacks/InitFcn”
e Define the value of the parameter k.

Main Callbacks History Description Data

Model callbacks Model initialization function:
PreLoadFcn
PostLoadFcn
InitFcn*
StartFcn
PauseFcn
ContinueFcn
StopFcn
PreSaveFcn
PostSaveFcn
CloseFcn

k=-1;

OK Cancel Help Apply



Using the Parameter

Set light equal to k and run the simulation to see an inverted square wave

File Tools View Simulation Help L]

@- 40P =- aQ- Q- §&&-

on_off

® |"a/my_switch » [ Jon_off

Power_on
entry:light=k;

® 0O ¢ o [

D';

I & &

Ready Sample based T=100.000

Ready 164% FixedStepDiscrete



